Support for new engine

Post Reply
Els07
Posts: 2
Joined: Mon Jan 27, 2020 9:10 am

Support for new engine

Post by Els07 » Mon Jan 27, 2020 11:29 am

Hello, my engine is not compatible? Nothing can be done? Am or Skoda Octavia 2.0 TDI BMM 140CP (103KW) 2009.
Thank you!

User avatar
admin
Site Admin
Posts: 75
Joined: Sun Jun 02, 2019 10:58 pm

Re: Support for new engine

Post by admin » Mon Jan 27, 2020 3:02 pm

The app was developed on the diagnostic protocol available in 2017, that actually is still the last available for VAG.
Your engine uses the old protocol that was replaced about in years 2010-2011, depending on car model and brand.
Unfortunately, these 2 protocols don't share anything. I tried to analyze the old protocol, but I've found many problems, first of all the unavailability of a car for test and debug. It was impossible to ask every time to a friend for a new code line checking. Moreover, the ELM spec doesn't seem to like the VW TP-2.0 (the old protocol) and many functions should be adapted with workarounds... this means many debug iterations.

I decided to abort the activity because for my available time, it would be too long.
I know there are many owners of that kind of car and I would be happy to help them, but for my limited resources, now it's impossible.

Post Reply