ELM 327

Post Reply
alonzo
Posts: 1
Joined: Sun Feb 16, 2020 8:05 pm

ELM 327

Post by alonzo » Sun Feb 16, 2020 8:13 pm

Hello Guys i want to know if my ELM 327 v1.5 is not Fake .. i used the ELM 327 identifier from google play and i obtained the result below , i need an answer and thx
Attachments
Screenshot_20200216_211154.jpg
result

User avatar
admin
Site Admin
Posts: 232
Joined: Sun Jun 02, 2019 10:58 pm

Re: ELM 327

Post by admin » Mon Feb 17, 2020 10:21 am

I's impossibile to understand if an adapter is fake only checking the results of the app.
What we can see is that your adapter works as an ELM327 with firmware 1.4 and it fulfills that ELM specs, but it declares to be version 1.5 (that doesn't exist).

I think it's a cloned china version adapter, but this doesn't mean it's a bad adapter. The real quality (speed and reliability) will be revealed only using it.

Jappglapp
Posts: 3
Joined: Thu Jan 28, 2021 12:58 pm

Re: ELM 327

Post by Jappglapp » Thu Jan 28, 2021 1:20 pm

Hi!

Looks like I also managed to buy a fake ELM327. It lies to v2.1, but not even to 1.4.

What phenomenon do the communication errors listed below cause? Just one data doesn’t show up, doesn’t work? Or can it cause misinformation?
What I suspect: I’m sure STFT gives me the wrong sign. When the ECU go to lean, the STFT writes positive instead of negative. Respectively, it does not display the signal of the wideband oxygen sensor (mA, Volt, or ratio, or%) in any way. These problems also apply to 4 different google play software.
VW Golf4 1.6 16V AZD, my car.
This could be due to a fake ELM or other communication thing. for example, the ELM cannot read the wideband probe signal from the outset?
Screenshot_20210127-161756_ELM327 Identifier.jpg
Screenshot_20210127-161843_ELM327 Identifier.jpg
Screenshot_20210127-161839_ELM327 Identifier.jpg
Screenshot_20210127-161832_ELM327 Identifier.jpg
Screenshot_20210127-161825_ELM327 Identifier.jpg

User avatar
admin
Site Admin
Posts: 232
Joined: Sun Jun 02, 2019 10:58 pm

Re: ELM 327

Post by admin » Thu Jan 28, 2021 6:03 pm

The app can't test the adapter in a so detailed way. It just ask to the adapter if the AT command is known, but how it manages the command can't be tested with the device-to-adapter connection. It would be necessary to connect also the other side of the communication line and to perform a real communication test with requests and replies with a completely different approach.

My app is just a quick check, if the results are not ok, probably the adapter uses a cloned fake firmware, on the contrary if they are ok, this simply means that the adapter can manage the commands but you don't know how it manages them.

Jappglapp
Posts: 3
Joined: Thu Jan 28, 2021 12:58 pm

Re: ELM 327

Post by Jappglapp » Thu Jan 28, 2021 9:59 pm

Okkay! Thanks for your detailed answer! And thanks for the identifier app too. Can you possibly recommend a company, a website where I can definitely buy an original ELM327? I would be primarily interested in the USB cable version. I searched the net, but I see it is flooded with their fake gadgets. There are many in v1.5 for example.

User avatar
admin
Site Admin
Posts: 232
Joined: Sun Jun 02, 2019 10:58 pm

Re: ELM 327

Post by admin » Fri Jan 29, 2021 4:46 pm

I own an Obdlink LX adapter that is worldwide known as very good. It uses an STN chip instead of ELM, but it's fully compatible with ELM specification and add more commands and programmable options for professional use.

Obdlink has also an USB version that, I suppose, has the same quality. I don't have experience with USB adapters si I can't give you an advice.

Please note that my apps don't support USB adapters actually. I planned to add this compatibility, but not in the near future.

Jappglapp
Posts: 3
Joined: Thu Jan 28, 2021 12:58 pm

Re: ELM 327

Post by Jappglapp » Sun Jan 31, 2021 2:40 pm

I understand everything. Thank you very much for your help. I will try the USB or BT version.

Post Reply