Dongle issue

Post Reply
apptester
Posts: 15
Joined: Sat Feb 29, 2020 12:24 pm

Dongle issue

Post by apptester » Sat Feb 29, 2020 12:28 pm

Got Proscan Automotive dongle advertised as Mini ELM327 OBD2 V2.1, however vag dpf free i snot supported as well as protocol goes only to v2, not v2.1 as advertised. Dongle is being returned but I would like to know if version needs to be > 2 to support vag dpf app?
thanks
Screenshot_20200229-103456_ELM327 Identifier.jpg
Screenshot_20200229-103321_VAG DPF free.jpg

User avatar
admin
Site Admin
Posts: 157
Joined: Sun Jun 02, 2019 10:58 pm

Re: Dongle issue

Post by admin » Mon Mar 02, 2020 11:18 am

The ELM327 identifier report doesn't tell you if the adapter works with every supported command, it only reports which commands are recognized by the adapter, but during its functioning it couldn't manage well some of them, as usually happens with low cost adapters.

apptester
Posts: 15
Joined: Sat Feb 29, 2020 12:24 pm

Re: Dongle issue

Post by apptester » Thu Mar 05, 2020 12:04 am

Dongle from ebay description says it supports following:

ISO 15765-4 CAN (11 bit ID, 500 kbaud)

ISO 15765-4 CAN (29 bit ID, 500 kbaud)

ISO 15765-4 CAN (11 bit ID, 250 kbaud)

ISO 15765-4 CAN (29 bit ID, 250 kbaud)

So I guess this is a good case for return because it does not match description.
:?:

User avatar
admin
Site Admin
Posts: 157
Joined: Sun Jun 02, 2019 10:58 pm

Re: Dongle issue

Post by admin » Thu Mar 05, 2020 5:15 pm

VAG DPF requires at least an ELM327 version 1.3.

If your dongle declares the v2.1 compatibility, you can return it because the support is only partial, watching the ELM327 identifier report.
Support for the 4 versions of ISO 15765 protocol is present since version 1.0 of the ELM firmware, but in any case also if a dongle would supports every AT command, if it works bad you should return it.

pawel
Posts: 3
Joined: Sat Aug 22, 2020 6:45 am

Re: Dongle issue

Post by pawel » Sat Aug 22, 2020 7:01 am

Hello
The Chinese use the ELM327 identifier app as a quality feature.
That is why they manipulated the firmware in such a way that AT commands are declared as OK, which in truth are not supported at all.
These dongles can then not work with programs that rely on configuration with AT commands.
These dongles are only optimized for the automatic detection of OBD2 protocols.


Since the ELM327 identifier app does not check the ATPPS command, this manipulated firmware cannot be identified.

Please also read here: https://cvtz50.info/en/elm327/

User avatar
admin
Site Admin
Posts: 157
Joined: Sun Jun 02, 2019 10:58 pm

Re: Dongle issue

Post by admin » Sat Aug 22, 2020 10:35 am

I agree, I always said and written that the ELM327 identifier results aren't an assurance both if ok or not ok. They're only an indication of the adapter quality.

The article you posted is interesting, but why do you think the ATPPS command is the only one that confirms the adapter firmware reliability? Couldn't it be manipulated by a firmware cracker like other commands?

Anyway I can manage to introduce the ATPPS command.

pawel
Posts: 3
Joined: Sat Aug 22, 2020 6:45 am

Re: Dongle issue

Post by pawel » Sat Aug 22, 2020 1:27 pm

You could expand your log file and show the Elm Response messages.
That would increase transparency.
There is, for example, chinese WiFi Elm with a real 1.4 (1.5) AT command set, which sends a ü in response to ATZ.
This Elm type has problems with software which is ASCII coded and uses this command to configure the protocol.

User avatar
admin
Site Admin
Posts: 157
Joined: Sun Jun 02, 2019 10:58 pm

Re: Dongle issue

Post by admin » Sun Aug 30, 2020 11:12 am

Using your good suggestions, I released now a new version with ATPPS command and raw results in the log.

Thanks

pawel
Posts: 3
Joined: Sat Aug 22, 2020 6:45 am

Re: Dongle issue

Post by pawel » Sun Sep 13, 2020 7:04 pm

Thanks for your quick implementation.
Can you please add ATSI and ATFI?
These commands are also required for older Renault Ecu in order to select the KWP protocol directly.

User avatar
admin
Site Admin
Posts: 157
Joined: Sun Jun 02, 2019 10:58 pm

Re: Dongle issue

Post by admin » Tue Sep 15, 2020 9:59 am

I can't add these commands because they don't give any answer back so the app can't understand if they're accepted correctly or not.

Post Reply