Page 1 of 1

Erratic Differential Preassure readings

Posted: Thu Jul 18, 2019 11:21 am
by rubadubdub
Hi.
I have a CAAC engine (2013 VW Transporter T5.1) and the app seems to be working correctly except that the differential pressure reading is continually erratic showing anything from minus figures to +160 hPa, even when engine is stopped.
Could this mean the app is incompatible with this particular engine to have this behavior?
Or could it be showing it has a faulty sensor? I am currently having problems with the vehicle constantly regenerating.
Your help would be greatly appreciated.
Steve

Re: Erratic Differential Preassure readings

Posted: Sun Jul 21, 2019 2:54 pm
by misu tdi
Is not there anyone here?

Re: Erratic Differential Preassure readings

Posted: Tue Jul 23, 2019 10:07 am
by admin
The differential pressure field, for some engines, is given from similar engines that share all the other fields.
Unfortunately I don't have the full map of measuring blocks for every VAG engine.

Can you verify the differential pressure values using another tester like VCDS or ODIS? A wrong calculation of raw values could be the reason.

Re: Erratic Differential Preassure readings

Posted: Wed Jul 31, 2019 5:07 pm
by rubadubdub
I have it in at a garage now to see what their test equipment shows up.
I will let you know the results.
Do you know what engine group the CAAC engine is in?
Cheers

Re: Erratic Differential Preassure readings

Posted: Fri Aug 02, 2019 9:22 am
by admin
I don't have any reports about CAAC engine. You should try every engine group looking for some working correctly.

About differential pressure issue, I don't have enough experience with that value, sincerely I can't evaluate your values.
But let me know the results of your investigation, I'm interested in that subject.

Bye
Daaren

Re: Erratic Differential Preassure readings

Posted: Sun Aug 18, 2019 9:18 pm
by rubadubdub
Hi Daaren.
I have news for you.
When we put the engine onto the test equipment at the garage they also got the same erratic readings from the DPF sensor.
They tested the sensor and it was okay, so the fault had to be somewhere else.
It was found out to be a short circuit in the wiring harness between the sensor and the ECU where a +12V wire was touching the +5V sensing circuit which was making the ECU give erratic results and trigger an unwarranted regeneration.
Once the wiring was fixed the readings became consistent with that of a correect DPF sensor showing between 1 - 20 mbar.
So the app is working good and it also showed up the fault on the sensor circuit.
I find all functions are working correctly for the CAAC engine when it is set to either group 3 or group 10 engines.

Re: Erratic Differential Preassure readings

Posted: Mon Aug 19, 2019 8:41 am
by admin
Very good! Your report will be useful for other people for sure.

Sometimes they ask me to check if the differential pressure values are correct, but I can't say that because I don't have experience about sensor failures.
Your report give us an evidence of a possible failure.

Thanks