Connection OK but cannot read ECU data

Post Reply
thegreektaxi
Posts: 2
Joined: Tue Oct 06, 2020 2:30 pm

Connection OK but cannot read ECU data

Post by thegreektaxi » Tue Oct 06, 2020 2:51 pm

Car: Skoda Superb 2020 TDI 2.0 150PS
Generic ELM327 dongle

Wifi/ Bluetooth: Green
Dongle icon: Green
Car icon: Yellow
Recycle icon: Green then grey.
Blue dot in all cells.

I get the message: No data from ECU.

Any idea?

Thanks a lot for accepting me ;)

User avatar
admin
Site Admin
Posts: 150
Joined: Sun Jun 02, 2019 10:58 pm

Re: Connection OK but cannot read ECU data

Post by admin » Wed Oct 07, 2020 8:23 am

Your car is recent so I think your engine is using the last diagnostic protocol for sure.
Usually all recent engines are at least partially compatible with the app, but almost always they're fully compatible.
With a good ELM adapter you should see at least the ECU data at the bottom of the screen, but if you see error message instead, I suspect your adapter isn't working well, as many of the low cost generic adapter.
First you should find the engine code so I can confirm you if it's supported, then you should buy a good adapter.

You can see a specific question in the FAQ with some examples:
viewtopic.php?f=9&t=319

thegreektaxi
Posts: 2
Joined: Tue Oct 06, 2020 2:30 pm

Re: Connection OK but cannot read ECU data

Post by thegreektaxi » Wed Oct 07, 2020 8:32 am

Thanks a lot for getting back.
My engine code is CRBC.

User avatar
admin
Site Admin
Posts: 150
Joined: Sun Jun 02, 2019 10:58 pm

Re: Connection OK but cannot read ECU data

Post by admin » Wed Oct 07, 2020 4:51 pm

The engine is supported ;)

Just a question: after the connection procedure, can you see ECU data at the bottom of the screen?
If yes, maybe the app is connected but you didn't start the data reading tapping on the filter image.
Otherwise if you don't see ECU data, the adapter can't read information from the ECU and the reason is probably its low quality.

Post Reply